When the agent attempts to connect to an IBM MQ Queue Manager, you may encounter the following error in the agent logs:
IME0005(<hostname>, <env>, <QMGR>): Unable to open Queue Manager: RC(2035)
In the MQ error logs, you may also see:
AMQ8077W: Entity '<userID>' has insufficient authority to access object <QMGR> [qmgr].
This indicates that the user ID under which the Meshiq agent is running does not have sufficient authority to connect to the MQ Queue Manager.
Cause
The MQ return code 2035 corresponds to “Not Authorized.”
This occurs when:
The user ID running the meshIQ agent does not have the required authority to connect to the Queue Manager.
Queue-level authorities are missing for that user ID.
Channel authentication (CHLAUTH) rules are restricting or remapping the connection.
Resolution
This issue needs to be addressed by the MQ administrators.
Confirm the user ID under which the meshIQ agent is running.
Review the MQ error logs to identify "insufficient authority" messages.
Ensure that the appropriate authorities are granted to the agent’s user ID on the Queue Manager, queues, and topics as required.
Review CHLAUTH rules to confirm there are no blocks or unintended user mappings.
Once the MQ administrators grant the necessary authorities, the meshIQ agent will be able to connect successfully.